提示:其他語言是Google翻譯的。 你可以訪問 English 版本。
登入
x
or
x
x
註冊
x

or

如何在Excel中創建一個五星評級系統?

在我們的正常直播中,我們通常應用五星評級來判斷產品評分或客戶滿意度,如下圖所示,但是,如何在Excel工作表中創建五星級評分系統?

使用Excel中的條件格式創建五星級評分系統


使用Excel中的條件格式創建五星級評分系統


在Excel中, 條件格式 功能可以幫助您快速創建簡單的五星評級,請按照以下步驟進行操作:

1。 如下圖所示,將數據從1到5輸入數據旁邊的列中:

2。 然後輸入這個公式: =IF(C$1<=$B3,1,IF(ROUNDUP($B3,0)=C$1,MOD($B3,1),0)) 放入單元格C3中,然後將填充手柄向下拖動到要填充此公式的單元格中,請參見截圖:

備註:在上面的公式中, B3 該單元格是否包含評級號碼,以及 C1 是您在step1中輸入的第一個數字單元格。

3。 然後將填充手柄拖到要應用此公式的右側單元格中,您將看到以下結果,請參閱屏幕截圖:

4。 選擇公式單元格,然後單擊 主頁 > 條件格式 > 新規則,看截圖:

5。 在彈出 新的格式規則 對話框,請執行以下操作:

(1。)單擊 根據其值設置所有單元格選擇一個規則類型 列錶框;

(2。)在 格式樣式 下拉列表,選擇 圖標集 選項;

(3。)選擇 3明星 圖標 圖標樣式 下拉列表;

(4。)檢查 僅顯示圖標 選項;

(5。)在規則部分中,輸入 1 - 0.5 分開進入 文本框,並且都選擇 來自 類型 下拉列表。

6。 然後點擊 OK 按鈕,五星評級已插入到單元格中,請參閱截圖:


Kutools for Excel解決了您的大多數問題,並使您的生產率提高了80%

  • 重用: 快速插入 複雜的公式,圖表 以及你以前用過的任何東西; 加密單元格 密碼; 創建郵件列表 並發送電子郵件...
  • 超級方程式酒吧 (輕鬆編輯多行文字和公式); 閱讀佈局 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不丟失數據; 分裂細胞含量; 組合重複的行/列...防止重複的細胞; 比較範圍...
  • 選擇複製或唯一 行; 選擇空行 (所有細胞都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇......
  • 精確複製 多個單元格而不更改公式參考; 自動創建參考 多張表; 插入項目符號,複選框等等......
  • 提取文本,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級過濾器 (將過濾方案保存並應用到其他工作表); 高級排序 按月/週/日,頻率等; 特殊過濾器 用粗體,斜體......
  • 結合工作簿和工作表; 根據鍵列合併表; 將數據拆分為多個表格; 批量轉換xls,xlsx和PDF...
  • 超過300強大的功能。 支持Office / Excel 2007-2019和365。 支持所有語言。 在您的企業或組織中輕鬆部署。 全功能30天免費試用。
kte tab 201905

Office選項卡為Office提供選項卡式界面,使您的工作更輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,Publisher,Access,Visio和Project。
  • 在同一窗口的新選項卡中打開並創建多個文檔,而不是在新窗口中。
  • 通過50%提高您的工作效率,每天為您減少數百次鼠標點擊!
官方底部
Say something here...
symbols left.
You are guest ( Sign Up? )
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.
  • To post as a guest, your comment is unpublished.
    maliova · 1 months ago
    La formula en español es: =SI(C$1<=$B3;1;SI(REDONDEAR.MAS($B3;0)=C$1;RESIDUO($B3;1);0))
  • To post as a guest, your comment is unpublished.
    Zwyrvem · 3 months ago
    La formule en Français : =SI(C$1<=$B3;1;SI(ARRONDI.SUP($B3;0)=C$1;MOD($B3;1);0))
  • To post as a guest, your comment is unpublished.
    marcio · 1 years ago
    testei e não funciona a formula =SE(C$1<=$B3;1;SE(ARRED.PARA.CIMA($B3;0)=C$1;MOD($B3;1);0))