Log in  \/ 
x
or
x
x
Register  \/ 
x

or

How to create a five-star rating system in Excel? 

In our normal live, we usually apply the five-star ratings to judge the product ratings or customer satisfaction as following screenshot shown, but, how could you create a five-star rating system in Excel worksheet?

Create a five-star rating system with Conditional Formatting in Excel


Create a five-star rating system with Conditional Formatting in Excel


In Excel, the Conditional Formatting function can help you to quickly create a simple five-star rating, please do with the following steps:

1. Type the numbers from 1 to 5 into the columns beside your data as following screenshot shown:

2. Then enter this formula: =IF(C$1<=$B3,1,IF(ROUNDUP($B3,0)=C$1,MOD($B3,1),0)) into the cell C3, and drag the fill handle down to the cells you want to fill this formula, see screenshot:

Note: In the above formula, B3 is the cell contains the rating number, and C1 is the first number cell you have entered in step1.

3. And go on dragging the fill handle to right cells which you want to apply this formula, you will get the following result, see screenshot:

4. Select the formula cells, and then click Home > Conditional Formatting > New Rule, see screenshot:

5. In the popped out New Formatting Rule dialog box, please do the following operations:

(1.) Click Format all cells based on their values in the Select a Rule Type list box;

(2.) In the Format Style drop down list, choose Icon Sets option;

(3.) Select 3 Stars icon from the Icon Style drop down list;

(4.) Check the Show Icon Only option;

(5.) In the rules section, enter 1 and 0.5 separately into the Value text box, and both choose Number from the Type drop down lists.

6. Then click OK button, the five-star ratings have been inserted into the cells, see screenshot:


The Best Office Productivity Tools

Kutools for Excel Solves Most of Your Problems, and Increases Your Productivity by 80%

  • Reuse: Quickly insert complex formulas, charts and anything that you have used before; Encrypt Cells with password; Create Mailing List and send emails...
  • Super Formula Bar (easily edit multiple lines of text and formula); Reading Layout (easily read and edit large numbers of cells); Paste to Filtered Range...
  • Merge Cells/Rows/Columns without losing Data; Split Cells Content; Combine Duplicate Rows/Columns... Prevent Duplicate Cells; Compare Ranges...
  • Select Duplicate or Unique Rows; Select Blank Rows (all cells are empty); Super Find and Fuzzy Find in Many Workbooks; Random Select...
  • Exact Copy Multiple Cells without changing formula reference; Auto Create References to Multiple Sheets; Insert Bullets, Check Boxes and more...
  • Extract Text, Add Text, Remove by Position, Remove Space; Create and Print Paging Subtotals; Convert Between Cells Content and Comments...
  • Super Filter (save and apply filter schemes to other sheets); Advanced Sort by month/week/day, frequency and more; Special Filter by bold, italic...
  • Combine Workbooks and WorkSheets; Merge Tables based on key columns; Split Data into Multiple Sheets; Batch Convert xls, xlsx and PDF...
  • More than 300 powerful features. Supports Office/Excel 2007-2019 and 365. Supports all languages. Easy deploying in your enterprise or organization. Full features 30-day free trial. 60-day money back guarantee.
kte tab 201905

Office Tab Brings Tabbed interface to Office, and Make Your Work Much Easier

  • Enable tabbed editing and reading in Word, Excel, PowerPoint, Publisher, Access, Visio and Project.
  • Open and create multiple documents in new tabs of the same window, rather than in new windows.
  • Increases your productivity by 50%, and reduces hundreds of mouse clicks for you every day!
officetab bottom
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.
  • To post as a guest, your comment is unpublished.
    maliova · 5 months ago
    La formula en español es: =SI(C$1<=$B3;1;SI(REDONDEAR.MAS($B3;0)=C$1;RESIDUO($B3;1);0))
  • To post as a guest, your comment is unpublished.
    Zwyrvem · 7 months ago
    La formule en Français : =SI(C$1<=$B3;1;SI(ARRONDI.SUP($B3;0)=C$1;MOD($B3;1);0))
  • To post as a guest, your comment is unpublished.
    marcio · 1 years ago
    testei e não funciona a formula =SE(C$1<=$B3;1;SE(ARRED.PARA.CIMA($B3;0)=C$1;MOD($B3;1);0))