提示:其它语言是由 Google 机器翻译的。 你可以访问 English 版本。
登录
x
or
x
x
马上登记
x

or

如何在Excel中创建一个五星评级系统?

在我们正常的生活中,我们通常应用五星评级来判断产品评分或客户满意度,如下图所示,但是,如何在Excel工作表中创建一个五星评级系统?

在Excel中创建一个带有条件格式的五星级评分系统


在Excel中创建一个带有条件格式的五星级评分系统


在Excel中, 条件格式 功能可以帮助您快速创建简单的五星评级,请使用以下步骤做到:

1。 从1到5的数字输入数据旁边的列中,如下图所示:

2。 然后输入这个公式: =IF(C$1<=$B3,1,IF(ROUNDUP($B3,0)=C$1,MOD($B3,1),0)) 进入单元格C3,然后将填充手柄向下拖动到要填充此公式的单元格中,请参阅截图:

注意:在上面的公式中, B3 是单元格包含评级数字,和 C1 是您在step1中输入的第一个数字单元格。

3。 然后将填充手柄拖到要应用此公式的右侧单元格中,您将获得以下结果,请参阅截图:

4。 选择公式单元格,然后单击 主页 > 条件格式 > 新规则,看截图:

5。 在弹出 新的格式规则 对话框,请执行以下操作:

(1。)单击 根据其值设置所有单元格的格式选择一个规则类型 列表框;

(2。)在 格式样式 下拉列表,选择 图标集 选项;

(3。)选择 3星 从的图标 图标样式 下拉列表;

(4。)检查 仅显示图标 选项;

(5。)在规则部分,输入 1 0.5 分开进入 价值 文本框,并且都选择 来自 类型 下拉列表。

6。 然后点击 OK 按钮,五星评级已被插入到单元格中,请参阅截图:


Kutools for Excel解决了您的大多数问题,并使您的生产率提高了80%

  • 重用: 快速插入 复杂的公式,图表 以及你以前用过的任何东西; 加密单元格 密码; 创建邮件列表 并发送电子邮件...
  • 超级方程式酒吧 (轻松编辑多行文字和公式); 阅读布局 (轻松读取和编辑大量单元格); 粘贴到过滤范围...
  • 合并单元格/行/列 不丢失数据; 分裂细胞含量; 组合重复的行/列...防止重复的细胞; 比较范围...
  • 选择复制或唯一 行; 选择空行 (所有细胞都是空的); 超级查找和模糊查找 在许多工作簿中; 随机选择......
  • 精确复制 多个单元格而不更改公式参考; 自动创建参考 多张表; 插入项目符号,复选框等等......
  • 提取文本,添加文本,按位置删除, 删除空间; 创建和打印分页小计; 在单元格内容和注释之间转换...
  • 超级过滤器 (将过滤方案保存并应用到其他工作表); 高级排序 按月/周/日,频率等; 特殊过滤器 用粗体,斜体......
  • 结合工作簿和工作表; 根据键列合并表; 将数据拆分为多个表格; 批量转换xls,xlsx和PDF...
  • 超过300强大的功能。 支持Office / Excel 2007-2019和365。 支持所有语言。 在您的企业或组织中轻松部署。 全功能30天免费试用。
kte tab 201905

Office选项卡为Office提供选项卡式界面,使您的工作更轻松

  • 在Word,Excel,PowerPoint中启用选项卡式编辑和阅读,Publisher,Access,Visio和Project。
  • 在同一窗口的新选项卡中打开并创建多个文档,而不是在新窗口中。
  • 通过50%提高您的工作效率,每天为您减少数百次鼠标点击!
官方底部
Say something here...
symbols left.
You are guest ( Sign Up? )
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.
  • To post as a guest, your comment is unpublished.
    maliova · 3 days ago
    La formula en español es: =SI(C$1<=$B3;1;SI(REDONDEAR.MAS($B3;0)=C$1;RESIDUO($B3;1);0))
  • To post as a guest, your comment is unpublished.
    Zwyrvem · 1 months ago
    La formule en Français : =SI(C$1<=$B3;1;SI(ARRONDI.SUP($B3;0)=C$1;MOD($B3;1);0))
  • To post as a guest, your comment is unpublished.
    marcio · 1 years ago
    testei e não funciona a formula =SE(C$1<=$B3;1;SE(ARRED.PARA.CIMA($B3;0)=C$1;MOD($B3;1);0))